Subject: [PATCH] lagrange: build the_Foundation *without* werror

From: Dimitri Merejkowsky <[email-masked]>
Date: Mon, 3 May 2021 16:38:42 +0200

Otherwize the build breaks because :

* the default /etc/makepkg.conf sets -Wformat, -Werror=format-security
* the_Foundation's CMakeLists unsets -Wno-format
* a warning is produced
* ... and warning are treated as errors
---
 lagrange/PKGBUILD | 1 +
 1 file changed, 1 insertion(+)

diff --git a/lagrange/PKGBUILD b/lagrange/PKGBUILD
index 33b70e8..f84c3d7 100644
--- a/lagrange/PKGBUILD
+++ b/lagrange/PKGBUILD
@@ -24,6 +24,7 @@ makedepends=("cmake")
 build() {
     cmake -B build -S "$pkgname-${pkgver}" \
         -DCMAKE_INSTALL_PREFIX='/usr' \
+        -DTFDN_ENABLE_WARN_ERROR=OFF \
         -Wno-dev
     make -C build
 }
-- 
2.31.1

---

From: Roshless <[email-masked]>
Date: Mon, 3 May 2021 22:45:19 +0200

Thanks! Applied with bumped version.