Subject: [PATCH PKGBUILDs 1/2] pushgateway: Fix LDFLAGS

From: Thorben Günther <[email-masked]>
Date: Thu, 11 Jul 2024 20:25:38 +0200

pushgateway currently fails to build with:
flag provided but not defined: -Wl,--sort-common

This is caused by the flag parser being more strict.
The official package guidelines have been updated for this behaviour
[1].

[1]: https://wiki.archlinux.org/title/Go_package_guidelines
---
 pushgateway/PKGBUILD | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/pushgateway/PKGBUILD b/pushgateway/PKGBUILD
index f796f6f..cab51ef 100644
--- a/pushgateway/PKGBUILD
+++ b/pushgateway/PKGBUILD
@@ -17,7 +17,7 @@ source=("https://github.com/prometheus/pushgateway/archive/v${pkgver}.tar.gz"
 build() {
     cd $pkgname-$pkgver

-    LDFLAGS="-extldflags $LDFLAGS \
+    LDFLAGS="-extldflags \"$LDFLAGS\" \
 	-X github.com/prometheus/common/version.Version=$pkgver \
 	-X github.com/prometheus/common/version.Revision=$pkgver \
 	-X github.com/prometheus/common/version.Branch=tarball \

base-commit: 730cbf2815884f03a750652ce2d19804f1cfb07a
--
2.45.2

---

From: Thorben Günther <[email-masked]>
Date: Thu, 11 Jul 2024 20:25:39 +0200

---
 pushgateway/.SRCINFO | 6 +++---
 pushgateway/PKGBUILD | 4 ++--
 2 files changed, 5 insertions(+), 5 deletions(-)

diff --git a/pushgateway/.SRCINFO b/pushgateway/.SRCINFO
index 72a012f..c8404d2 100644
--- a/pushgateway/.SRCINFO
+++ b/pushgateway/.SRCINFO
@@ -1,6 +1,6 @@
 pkgbase = pushgateway
 	pkgdesc = Prometheus push acceptor for ephemeral and batch jobs.
-	pkgver = 1.8.0
+	pkgver = 1.9.0
 	pkgrel = 0
 	url = https://github.com/prometheus/pushgateway
 	arch = x86_64
@@ -9,9 +9,9 @@ pkgbase = pushgateway
 	makedepends = git
 	depends = glibc
 	options = !lto
-	source = https://github.com/prometheus/pushgateway/archive/v1.8.0.tar.gz
+	source = https://github.com/prometheus/pushgateway/archive/v1.9.0.tar.gz
 	source = pushgateway.service
-	sha512sums = cc09685da2c694e2a826dab40af4f8eb299ff88d10574152e6ebd0a35fb3c946a40b75618db17c9d8e43b5940b067be76880bb91ffbfa948cb828fda3d965186
+	sha512sums = e7bfba60858e626258b984f71640040260098eb27f2e5c8df0f70110500144db35e99bb2c74e1392f387771386368fcea586d08ffc20d4566ebcdcbfb07327e9
 	sha512sums = baf8f41a9643b7c8e9bdf59a38c6275df8861ed4c033de3ef3dd80ed8687d001724f43cad968d5f6c2d4c3541aa4d8b84d7c3a266f149e780c7168074b37f711
 
 pkgname = pushgateway
diff --git a/pushgateway/PKGBUILD b/pushgateway/PKGBUILD
index cab51ef..5710665 100644
--- a/pushgateway/PKGBUILD
+++ b/pushgateway/PKGBUILD
@@ -2,7 +2,7 @@
 # Contributor: Jelle van der Waa <[email-masked]>
 
 pkgname=pushgateway
-pkgver=1.8.0
+pkgver=1.9.0
 pkgrel=0
 pkgdesc="Prometheus push acceptor for ephemeral and batch jobs."
 arch=('x86_64')
@@ -45,5 +45,5 @@ package() {
 }

-sha512sums=('cc09685da2c694e2a826dab40af4f8eb299ff88d10574152e6ebd0a35fb3c946a40b75618db17c9d8e43b5940b067be76880bb91ffbfa948cb828fda3d965186'
+sha512sums=('e7bfba60858e626258b984f71640040260098eb27f2e5c8df0f70110500144db35e99bb2c74e1392f387771386368fcea586d08ffc20d4566ebcdcbfb07327e9'
             'baf8f41a9643b7c8e9bdf59a38c6275df8861ed4c033de3ef3dd80ed8687d001724f43cad968d5f6c2d4c3541aa4d8b84d7c3a266f149e780c7168074b37f711')
-- 
2.45.2